Top Seller



Twitter



Hosted By

Stacks Image 633

News & Announcements

The 32-bit Apocalypse

Please be aware that Apple has decided that from macOS 10.15 (Catalina) onward 32-bit games and applications don't deserve to exist. So please be aware of this before upgrading to macOS 10.15 or higher as POWERSLAM will not run in these versions of macOS.


Go back